Reports of app being slow/unavailable

Incident Report for Carta Europe

Resolved

This incident has been resolved.
Posted Nov 09, 2022 - 15:21 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 09, 2022 - 11:01 UTC

Investigating

We are currently investigating this issue.
Posted Nov 09, 2022 - 10:23 UTC
This incident affected: Application.