Email delivery failures

Incident Report for Carta Europe

Resolved

This incident has been resolved.
Posted Mar 01, 2024 - 20:13 UTC

Monitoring

Our email provider issues have been solved and email should now be flowing normally. We are keeping an eye close to the situation.
Posted Mar 01, 2024 - 19:53 UTC

Identified

There is an ongoing issue with our email provider causing delivery failures. We are in contact with our provider and the situation should be solved soon. Thank you for your patience.
Posted Mar 01, 2024 - 11:49 UTC